Kan du ikke gemme ændringer i PrestaShop?

Kan du ikke oprette / gemme ændringer på produkter i din PrestaShop?

For ca. 2 uger siden, udkom version 54 af Google Chrome. Det er en større opgradering der har ændret i den grundliggende måde browseren læser hjemmesiden på. En af de større ændringer er at de har fjernet XMLHttpRequest kald. Det er nemlig lige præcis den metode, som PrestaShop version 1.5 og 1.6 bruger til at oprette/redigere produkter.

I praksis så gør det det umuligt at oprette, ændre og gemme indhold i alle versioner af PrestaShop 1.5 og 1.6. Det er vigtigt at understrege at det ikke er en bug i PrestaShop, men derimod en konsekvens af ændringen i browseren Google Chrome (og andre browsere, der ligeledes har fjernet XMLHttpRequest kald).

Google Chrome opdaterer løbende sig selv, så det kan være svært at undgå at problemet vil opstå for dig også. Det vides pt. ikke hvornår andre browsere følger trop, og fjerner denne mulighed.

PrestaShop vil snart lancere en opdatering i version 1.6.1.9, hvor vil ændre dette, således at der ikke anvendes dette XMLHttpRequest kald.

Hvad kan jeg så gøre i mellemtiden?

Du kan installere den ældre version af Google Chrome (Version 53) og indstille det til ikke at auto-opgradere.

Du kan også skifte til Firefox, Safari eller Internet Explorer, hvor det pt. ikke vides hvornår de også fjerner denne mulighed.

Kilde: PrestaShop

Har du bruge for hjælp?

 

Så kontakt mig her nedenfor, og jeg kan evt. hjælpe dig over TeamViewer til at sætte en ny browser op, eller installere den ældre version af Google Chrome.

  1. Plakater siger:

    Det er godt nok irriterende, at Prestashop opfører sig sådan. Jeg håber snart, at problemet bliver løst.

    Skal sidde og tilføje omkring 200 plakater til min nye kategori, men hver gang jeg udfylder info om en plakat bliver det slettet. I gennemsnit tager det omkring 5 forsøg før Prestashop gemmer det.

    Jeg har simpelthen ikke tålmodighed til det, og er nødt til at vente med at tilføje mine plakater til der er kommet en løsning. Øv.

    Men tak for indlægget. Jeg var virkelig i vildrede over hvad der var galt indtil nu 🙂

    • Bendata ApS siger:

      Det glæder mig at du kunne bruge indlægget.

      Det er som nævnt i indlægget en mulighed at anvende Firefox eller en anden browser. Ellers kan det løses ved at opgradere shoppen til PrestaShop 1.6.1.8 eller nyere. Dette er typisk en mindre opgradering hvis du allerede har PrestaShop 1.6x.

      Du er meget velkommen til at skrive til mig på mail@bendata.dk, så vi evt. kan tage en dialog om at få din shop opgraderet 🙂

Skriv en kommentar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *